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Disclaimer  
 

Interactive Individual Identification 
System - Straighten version 1.0 

 
 
I3S Classic is free software; you can redistribute it and/or modify it under the terms of the 
GNU General Public License, version 2 or any later version published by the Free 
Software Foundation. 
 
This manual is released under the terms of the GNU Free Documentation License, 
version 1.1 or any later version published by the Free Software Foundation. 
 
This program is distributed in the hope that it will be useful, but  
WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY 
or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for 
more details. 
 
You should have received a copy of the GNU General Public License and GNU Free 
Documentation License along with the distribution (COPYING GPL v2.txt and 
COPYING.DOC.txt) If one of these files is missing, write to the Free Software 
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. 
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1 Introduction 

1.1 What is I
3
S Straighten? 

I
3
S Straighten is an additional tool to the family of photo-identification software tools called I

3
S. I

3
S 

Straighten helps to correct for curvature of the body in the 2D plane. As correction of overall body 
position requires a 3D model of the animal’s body, I

3
S Straighten can only correct for a limited 

number of deformations caused by body curvature. It is expected that the relevant area used for 
photo-identification is (more or less) in the same plane. An example where I

3
S Straighten can be 

useful is correction of body curvature of newts. 
 
I
3
S Straighten will not do any identification; it only helps in preprocessing the images to obtain better 

results during identification. For identification the reader is referred to packages such as I
3
S Classic, 

I
3
S Spot or I

3
S Pattern. 

 
We refer in the remainder of this manual to I

3
S Straighten as I

3
S.  

1.2 Reading this document 

In this document all file names, directory names and shell commands are written using the font 

Courier New. All names relating to a part of the I
3
S user interface, such as button names or menu 

options, are boxed. If a message is particularly important the margin will show a large red boxed 

exclamation mark.  

1.3 Bug reports, comments and requests 

Please send all bugs, comments and questions to i3s [at] reijns.com. In case of a bug, describe 
clearly how we can reproduce the bug ourselves. If possible provide us with all relevant data such as 
images and fgp-files. We will always treat your data as confidential. Data will not be distributed to 
others without your explicit consent.  
 

In case of errors I
3
S Straighten may write a log file in the C:\ main directory as 

I3SStraighten_error_<data>_<time>.log. Please include these files in your bug reports. 

1.4 System requirements 

This version of I
3
S requires a Windows 32-bits or 64-bits operation system 

(XP/Vista/Windows7/Windows8). The software is developed using Java 1.8 and C++ (MS Visual C++ 
2010). Both Java and most of the C++ code are platform independent and it should therefore be 
relatively simple to port it to other platforms such as Linux or Mac OS. 
 
Hardware requirements are at least 2GB of memory (preferably 4GB) and a 2 GHz CPU or faster. 
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1.5 Software and data requirements 

Because the main program is developed in Java, the Java Run-time Environment (JRE) is required. 
This distribution will only work with a 32-bits JRE version 1.8.0 or higher! The JRE 8 (or higher) 
can be downloaded for free from the Java website or Oracle website. 
 
Note: I

3
S currently only works with the 32-bits version of the JRE. I

3
S has been developed on a 64-

bits version of Windows 7, however with 32 bits JRE. If a 64-bit JRE is used, I
3
S will not work 

properly. 
 

I
3
S supports JPEG (extension .jpg) and GIF (extension .gif) images. Support of other image 

types is currently not foreseen as all known digital cameras can store images as JPEG. 

1.6 Installation 

Make sure you have administrator rights and turn User Account Control (UAC) off. UAC prevents the 
proper installation of the Windows environment variables. 
 

Run the file I3SStraighten_v1.0_Setup.exe. If your current Java version is not sufficient you 

will be notified and installation terminates. It is required to install the Java Runtime Environment 1.8.0 
(or higher) first.  
 
Apart from some information about the GNU-license, the installation consists of the following steps: 
1. Choosing the home directory where to install the program. Default will be in the directory  

C:\Program Files (x86)\I3SStraighten. 

 
2. You can indicate if you want I

3
S to create a folder in the Start menu folder.  

 
3. Finally, you can select some additional tasks: 
 

a. Creating a desktop item. 
b. Copy the source code. Only if you are interested in using or changing the source code 

you need to check this item. 

1.7 Uninstall 

You can uninstall I
3
S in two simple steps: 

 
1. Uninstall I

3
S, using the entry in the start menu.  

 
2. Optionally you can also uninstall the Java Runtime Environment (JRE). In general it is not a good 

idea to uninstall JRE without replacing it for a newer version because other programs may 
depend on it. However, if you still want to uninstall JRE use the standard procedure: Select 
Programs and Features in the Control Panel. Then select the appropriate item from the list and 
click on the Add/Remove button.  



I
3
S Straighten Manual, v1.0, April 2015  

 
 
 
 
 

6 

1.8 Quick introduction with a video tutorial 

An example is shown in our instruction video at the I
3
S YouTube channel. The links to our channel is 

also available at the website and via the Help menu. 

 
. 

https://www.youtube.com/channel/UC0QLj0fuquYTJFe4xe6TKFQ
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2 The I
3
S user interface 

This chapter will address the possibilities of the I
3
S user interface. First, the menu bar and toolbar are 

described. Next, the interaction with the annotation panel is discussed. 

2.1 The menu bar 

I
3
S offers a standard Windows look & feel menu-based interface to perform most operations. In the 

paragraphs below, the three menu items will be explained. An overview of the title and menu bar is 
shown in Figure 2-1. 
 
 

 

Figure 2-1: The I
3
S menu bar. 

 

2.1.1 The File menu 

This is the main I
3
S menu. Figure 2-2 shows the operations, which are discussed below: 

 
 

 

Figure 2-2: The file menu. 

 

 Open image (shortcut CTRL+O). It will open a window to choose an image file. The supported 

image types are JPEG and GIF. The starting directory will be the last directory you visited with 
I
3
S.  

 

 Close image. It closes the image in the main window. If you have unsaved data I
3
S will prompt 

you whether you want to save the data first. 
 

 Exit (shortcut CTRL+X). This operation will close all windows. In case of unsaved data I
3
S will 

prompt you whether you want to save the data first. 
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2.1.2 The Options menu 

Optional settings allow you to change the optional settings with the window shown in Figure 2-3. 

 
 

 

Figure 2-3: The option window. 

 
 
The options allow you to change the drawing settings used by I

3
S: 

 The color of the control points to indicate the path along the animal’s body.  

 The color of the smoothed estimation of the body curve. 

 The color of the overlay area which indicates the part of the image taken along in the 
straightening process. 

 The width of the lines drawn by I
3
S. 

2.1.3 The Help menu 

 

 Open manual will start your default PDF reader and open this manual. 

 

 Go to the I3S website will open your default web browser and show the I
3
S website. 

 

 Video tutorials at the I3S YouTube channel will open your default web browser and shows the 

start page of the I
3
S channel at YouTube. 

 

 Follow us on Facebook will open your default web browser and shows the Facebook page of I
3
S. 

 

 About I3S… shows a window with information on version number, authors, copyright and contact 

details.  
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Figure 2-4: The Help menu. 

2.2 The tool bar 

Below the menu bar I
3
S shows a tool bar, which offers short cuts to functions described in the 

previous paragraphs and some new functions. An overview of the tool bar is shown in Figure 2-5. 
 
 

 

Figure 2-5: The tool bar. 

 
The table below describes the various items in detail. If buttons are gray, you are not at a point in the 
workflow where you can use them. Either you need to provide more input, or you must go back to a 
previous step. 
 
 

 
Open file. 

 
Save file. 

,    and   
Controls for zoom. Pressing the plus will zoom 
in on the image. If the enlarged image does not 
fit the screen two sliders will appear. The 
mouse wheel can also be used for zooming. 
The minus will zoom out. The zoom factor is 
displayed right of the minus. The maximum 
allowed zoom factor is 1000%. 

 or  
Finalize the curve. Fit a smooth curve through 
the control points. At least three control points 
are required. 

  or  
Straighten the image based on the smooth 
curve. 

 or  
Reject the outcome of the straightening process 
and return to the control point selection step. 
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A text field, which will show instructions which 
input is required. If a message is shown, the 
field will be yellow. 

 
A slider to adjust the buffer along the smoothed 
curve which indicates the part of the image that 
will be included in the straightening process. 

2.3 The straightening process 

The straightening process consists of 3 steps detailed below: 
1. Selection of control points to indicate the general area of interest and the curvature of the 

body. 
2. Fitting of a smooth curve and size of area of interest. 
3. Straightening of the image. 
 

 

 

Figure 2-6: Control points in green along the curved body of a Great Crested Newt  
(image from University of Eastern Finland). 

 

2.3.1 Selecting the control points 

Click in the image with the left mouse button along the curved body of the animal to add control 
points. In case the body has high curvature, use more control points. Make sure you cover the entire 
area used for identification, including the three reference points (we refer you to the manuals of the 
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various I
3
S identification packages for more information on reference points). Figure 2-6 shows an 

example. By clicking on the right mouse button, the last control point is removed. 
 
You are advised to always follow the same path along the body, e.g. always head to tail, regardless 
of the orientation in the image. By doing this all the images will have the same orientation which will 
make processing with one of the other I

3
S packages easier. 

 
 
 

 

Figure 2-7: Smoothed curve in blue through the green control points. The transparent area in red 
shows the part of the image which will be straightened. 

 

2.3.2 Smoothening and area selection 

If you have added enough control points (three minimum), click on the green finalize button . You 
will see a smoothed curve through the selected control points and a partly transparent area which 
shows the part of the image which will be included in the actual straightening. Drag the slider to the 
left or right to resp. decrease or increase the transparent area. You will see the transparent area 
change when adjusting the slider. You are advised to select only the part of the image required for 
identification and reference points.  
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2.3.3 Straightening 

If you are satisfied with your selection, click on the process button . If not click with the right mouse 
button to return to remove the last control point and return to the control point selection. When 
clicking on ‘process’ you will see the straightened image shown in Figure 2-8. To finalize the process 

click on the save button. If the result is not to your liking, click on the reject button  to remove the 
results and return to the control point selection. 
 
 
 

 

Figure 2-8: Straightened image using the settings shown in Figure 2-7. 
Please note that the tail area is now on the left because the image 

was annotated tail to head. 


